Средство диагностики DirectX

Средство диагностики DirectX

Справка по средству диагностики Microsoft® DirectX® включает следующие разделы.

  • О средстве диагностики DirectX
  • Поиск информации
  • Тестирование компонентов DirectX
  • Переопределение характеристик по умолчанию


О средстве диагностики DirectX

Средство диагностики Microsoft® DirectX® позволяет не только получать сведения о компонентах интерфейса программирования приложений DirectX и драйверах компьютера, но и выполнять тестирование звуковых и графических данных на выходе, а также поставщиков служб Microsoft DirectPlay®. Кроме того, пользователь имеет возможность отключить некоторые средства аппаратного ускорения.

Данное средство позволяет выполнить сбор сведений, которые потребуются при обращении в службу технической поддержки, а также включить собранную информацию в сообщение электронной почты.

Информация представлена на нескольких страницах. Для переходов со страницы на страницу можно использовать любой из следующих способов:

  • Щелкните нужную вкладку.
  • Нажмите кнопку Следующая.
  • Нажмите клавишу СТРЕЛКА ВЛЕВО или СТРЕЛКА ВПРАВО, когда фокус ввода находится на вкладке.

Чтобы сохранить све сведения в текстовом файле, нажмите кнопку Сохранить все сведения.

Примечание. Некоторые данные, такие как объем памяти на видеоплате, могут быть указаны приблизительно.


Поиск информации

Средство диагностики Microsoft® DirectX® помогает обнаружить источники неполадок при выполнении приложений DirectX. Ниже перечислены некоторые возможные источники неполадок.

  • Неправильные версии компонентов DirectX. В разделе Примечания страницы Файлы DirectX просмотрите предупреждения о бета-версиях и отладочных файлах. Бета-версии являются ранними пробными версиями, которые не должны устанавливаться коммерческими приложениями. Отладочные версии, которые используются при разработке программ, также не должны устанавливаться конечными продуктами, поскольку они выполняются существенно медленнее коммерческих версий соответствующих компонентов.
  • Отсутствие аппаратного ускорения. Некоторые программы выполняются очень медленно или вообще не выполняются в отсутствие аппаратного ускорения Microsoft DirectDraw® или Direct3D®. На странице Дисплей проверьте в группе Возможности DirectX, имеется ли для DirectDraw, Direct3D или для ускорения текстур AGP метка "Отсутствует". Если да, рассмотрите возможность обновления оборудования.
  • Устройство не подключено. Если джойстик или другое устройство ввода не отвечает, то возможно, оно было неверно установлено. Проверьте, что устройство включено в список на странице Ввод средства диагностики DirectX. Если нет, добавьте устройство с помощью панели управления.
  • Несертифицированные драйверы. Несертифицированные драйверы не были проверены Microsoft на полную совместимость с последней версией DirectX. Такие драйверы перечислены на странице соответствующих компонентов.


Тестирование компонентов DirectX

Microsoft® DirectDraw® и Direct3D® можно тестировать на любом мониторе, присоединенном к компьютеру, DirectSound® на любом звуковом выводном устройстве, а DirectMusic® на любом музыкальном порте.

Для тестирования DirectX нажмите кнопку Проверка на соответствующей странице, прочитайте появляющиеся сообщения и просмотрите или прослушайте тесты. Позвольте каждому тесту выполняться, пока не появится сообщение с вопросом, был ли тест успешным. Если пользователь ответит Нет, другие тесты не будут выполнены.

Для DirectMusic имеется всего один тест. Нажмите кнопку ОК, когда поймете, правильно ли воспроизводится музыка.

Кроме того, существует возможность тестирования функциональных возможностей Microsoft DirectPlay® для любого имеющегося поставщика служб.

процедура Чтобы проверить DirectPlay:

  1. На странице Сеть нажмите кнопку Проверить DirectPlay. В диалоговом окне Проверка DirectPlay введите имя пользователя и выберите поставщика службы. Выберите параметр Создать новый сеанс и нажмите кнопку ОК. Если было выбрано подключение через модем, нажмите кнопку Ответить в диалоговом окне Подключение через модем, чтобы перевести модем в режим автоответчика.
  2. Теперь запустите средство диагностики DirectX на другом компьютере, способном установить выбранное соединение с первым компьютером. Нажмите кнопку Проверить DirectPlay, введите другое имя пользователя, выберите того же поставщика службы, выберите параметр Подсоединиться к существующему сеансу и нажмите кнопку ОК.

    3. Для некоторых типов подключений может потребоваться указать дополнительные сведения, например номер телефона. Для подключений TCP/IP в локальной сети это поле можно оставить пустым.

  3. На втором компьютере должно появиться диалоговое окно Список сеансов, содержащее имя сеанса, созданного на первом компьютере. Выберите нужный сеанс и нажмите кнопку OK.
  4. На обоих компьютерах должно появиться окно разговора. Введите произвольное сообщение в область ввода на одном компьютере и нажмите кнопку Отправить. Это же сообщение должно появиться в области прокрутки диалогового окна разговора на обоих компьютерах.


Переопределение характеристик по умолчанию

На странице Звук можно изменить уровень аппаратного ускорения путем перемещения соответствующего бегунка. Этот уровень будет продолжать действовать после закрытия средства диагностики Microsoft® DirectX®.

Примечание. Эта возможность отсутствует в Microsoft Windows® 95.

На странице Дисплей для каждого дисплея, установленного на компьютере, можно с помощью кнопки Отключить отключить аппаратное ускорение для Microsoft DirectDraw® или Direct3D® (если средства аппаратного ускорения имеются). Даже после закрытия средства диагностики DirectX ускорение остается отключенным и недоступным для любых приложений. Чтобы снова включить ускорение, нажмите кнопку Включить на соответствующей странице.

Примечание. Отключение ускорения DirectDraw приводит к отключению ускорения для Direct3D.

Пользователь имеет также возможность переопределить частоту обновления монитора, установленную полноэкранными приложениями DirectDraw. Это следует делать только в том случае, если у некоторых приложений возникают неполадки с экраном, и имеются причины подозревать, что приложение устанавливает недопустимую частоту обновления.

процедура Чтобы переопределить частоту обновления:

  1. На странице Ничего не помогло? нажмите кнопку Перекрыть.
  2. В диалоговом окне Перекрытие частоты обновления экрана DirectDraw выберите поле и введите частоту обновления, допустимую для вашего монитора.

    3. При этом автоматически выбирается параметр Другое значение.

  3. Нажмите кнопку OK.

процедура Чтобы отменить переопределение частоты обновления и позволить приложениям DirectDraw задавать собственную частоту обновления:

  1. На странице Ничего не помогло? нажмите кнопку Перекрыть.
  2. В диалоговом окне Перекрытие частоты обновления экрана DirectDraw выберите параметр По умолчанию и нажмите кнопку ОК.


Раздел не найден

Подходящий раздел не найден. Возможные причины и способы устранения неисправности:

  • Содержащий нужный раздел файл (.chm) находится в другом месте.

    • Устранение: перезапустите установку библиотеки MSDN.

  • Устарел файл (.chm), содержащий текущий или указанный раздел, и эта ссылка больше недоступна.

    • Устранение: установите последнюю версию библиотеки MSDN.

  • Компакт-диск библиотеки MSDN не вставлен в дисковод.

    • Устранение: вставьте компакт-диск библиотеки MSDN в дисковод.